Victoria Day Funding Delay - May 19, 2025

Incident Report for PayFacto

Resolved

Funding is completed.
Posted May 22, 2025 - 10:26 EDT

Monitoring

We will be monitoring the deposits.
Posted May 12, 2025 - 16:06 EDT

Identified

Due to the bank holiday, deposits for transactions processed between May 16 and May 18 will be made on Tuesday May 20, instead of Monday May 19.

Thank you for your understanding.
Posted May 12, 2025 - 15:57 EDT
This incident affected: Funding (Funding Canada).