Funding Delay - Friday April 11th, 2025

Incident Report for PayFacto

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 08:45 EDT

Identified

We have been notified by our banking partner that there is a delay for the April 11th, 2025 deposit of transactions processed on April 10th, 2025.

Funding for these transactions should be completed later today.

We sincerely apologize for any inconvenience this may cause.
Posted Apr 11, 2025 - 09:42 EDT
This incident affected: Funding (Funding Canada).