Connection Issue with the DataBoard Application

Incident Report for PayFacto

Resolved

The login issue affecting the DataBoard application for Maitre'D has been resolved. Merchants should be able to access the application as normal.

Thank you for your patience and understanding.
Posted Nov 04, 2025 - 15:18 EST

Monitoring

Merchants are currently unable to log into their DataBoard application for Maitre'D. The cause of the problem is currently being investigated and more details will follow.

We apologize for any inconvenience this may cause you.

Thank you for your understanding.
Posted Nov 04, 2025 - 10:52 EST
This incident affected: Reporting Portals (Databoard MaitreD').