Upcoming Thanksgiving Funding Delay (Canada)
Incident Report for PayFacto
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 08:56 EDT
Identified
Folllowing our recent Thanksgiving Funding Delay communication, the payment of transactions processed from October 11 to 13 is completed.

Thank you for your trust.
Posted Oct 11, 2024 - 09:17 EDT
This incident affected: Funding (Funding Canada).