Easter Holiday Funding Delay

Incident Report for PayFacto

Resolved

Funds have been deposited.
Posted Apr 22, 2025 - 10:20 EDT

Investigating

Due to the bank holiday, payments for transactions processed on Thursday April 17, 2025 will be delayed.

Funding for these transactions will now be made on Monday April 21, instead of Friday April 18.

Thank you for your understanding.
Posted Apr 14, 2025 - 09:19 EDT
This incident affected: Funding (Funding Canada).