(U.S.) Independence Day Funding Delay - July 4th, 2025

Incident Report for PayFacto

Resolved

Funding is complete.
Posted Jul 09, 2025 - 08:59 EDT

Monitoring

Due to the bank holiday for Independence Day, payments for transactions processed on Thursday, July 3rd, 2025 will be delayed. Funding will occur on Monday, July 7, 2025.

Please note that deposit times may vary depending on your financial institution.

Thank you for your understanding.
Posted Jul 02, 2025 - 10:50 EDT
This incident affected: Funding (Funding USA).