(U.S.) Funding Delay Notification - March 3, 2026

Incident Report for PayFacto

Resolved

This funding delay is resolved.
Posted Mar 09, 2026 - 16:29 EDT

Monitoring

We have been informed of a funding delay affecting the March 3, 2026 deposit for transactions processed on March 2, 2026. Our banking partner is working to resolve the issue and ensure all transactions are processed as quickly as possible.

We apologize for any inconvenience this may cause.
Posted Mar 03, 2026 - 12:14 EST
This incident affected: Funding (Funding USA).