Saint-Jean-Baptiste Holiday Funding Delay - June 24, 2025 (Province of Quebec only)

Incident Report for PayFacto

Resolved

Funding is complete.
Posted Jun 26, 2025 - 10:40 EDT

Monitoring

Due to the banking holiday in Quebec, payments for transactions processed on Monday, June 23rd will be made on Wednesday, June 25th.

Please note that deposit times may vary depending on your financial institution.

Thank you for your understanding.
Posted Jun 19, 2025 - 15:49 EDT
This incident affected: Funding (Funding Canada).