Thanksgiving Funding Delay - Monday, October 13, 2025

Incident Report for PayFacto

Resolved

Funding is complete.
Posted Oct 15, 2025 - 08:33 EDT

Monitoring

Due to the Thanksgiving bank holiday, the payment for transactions processed between October 10 and 12 will be delayed.

Funding for these transactions will be made on Tuesday, October 14, instead of Monday, October 13.

Thank you for your understanding.
Posted Oct 06, 2025 - 12:34 EDT
This incident affected: Funding (Funding Canada).