(U.S.) Memorial Day Payment Delay

Incident Report for PayFacto

Resolved

Funding is complete.
Posted May 28, 2025 - 11:39 EDT

Monitoring

The payment of transactions processed between May 23 and May 25 will be delayed due to
the bank holiday.

Deposits for these transactions will be made on Tuesday May 27 instead of Monday May 26.

Thank you for your understanding.
Posted May 22, 2025 - 10:36 EDT
This incident affected: Funding (Funding USA).