Labour Day Funding Delay: September 2nd, 2024
Incident Report for PayFacto
Resolved
Dear merchants and partners,

As scheduled, funding for the transactions processed from August 30th to September 2nd 2024 were deposited on Tuesday September 3rd.

Thank you for your trust.

PayFacto
Posted Sep 04, 2024 - 09:53 EDT
Identified
Dear merchants and partners,

The payment of transactions processed from August 30th to September 2nd 2024, will be delayed due to the bank holiday. Funding for these transactions will be made on Tuesday September 3rd instead of Monday September 2nd.

We apologize for any inconvenience this may cause you.

Thank you for your understanding.

PayFacto
Posted Aug 23, 2024 - 15:46 EDT
This incident affected: Funding (Funding Canada).