National Day for Truth and Reconciliation Funding Delay - September 30, 2025

Incident Report for PayFacto

Resolved

Funding is complete.
Posted Oct 01, 2025 - 15:23 EDT

Monitoring

The payment of transactions processed on Monday, September 29, 2025 will be delayed due to the holiday. These transactions will be deposited on Wednesday, October 1st instead of Tuesday, September 30.

Thank you for your understanding.
Posted Sep 25, 2025 - 13:25 EDT
This incident affected: Funding (Funding Canada).