President's Day Holiday Funding Delay (USA) - February 16, 2026

Incident Report for PayFacto

Resolved

Funding is complete.
Posted Feb 18, 2026 - 17:46 EST

Monitoring

In observance of the President's Day holiday, we would like to inform you that the payment for transactions processed between February 13 and 15 will be delayed.

Funding for these transactions will be made on Tuesday, February 17, 2026, instead of Monday, February 16, 2026.

Thank you for your understanding.
Posted Feb 16, 2026 - 09:13 EST
This incident affected: Funding (Funding USA).